re = /([\w-]*)\s*:\s*([^;]*)/
str = ' border:solid 1px; color:red; background-image: url(\'http://example.com/image.png\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end