$re = '/([\w-]*)\s*:\s*([^;]*)/';
$str = ' border:solid 1px; color:red; background-image: url(\'http://example.com/image.png\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);