const regex = /(?:(?:.*?,){6})(?<email>.*?),(?:(?:.*?,){2})(?<phone>.*?),.*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:.*?,){6})(?<email>.*?),(?:(?:.*?,){2})(?<phone>.*?),.*$', 'mg')
const str = `55451,31.173.84.144,Ирина,10,100medspravok.com,,rinazhukova77@gmail.com,МСК,1481572814,9265837548,778899,1,0,1
55452,149.13.91.87,Антон,0,100medspravok.com,,adm.bitgram@gmail.com,МСК,1481572822,9111460148,ДшЫЙ7рйо,0,1,1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}