use strict;
my $str = '55451,31.173.84.144,Ирина,10,100medspravok.com,,rinazhukova77@gmail.com,МСК,1481572814,9265837548,778899,1,0,1
55452,149.13.91.87,Антон,0,100medspravok.com,,adm.bitgram@gmail.com,МСК,1481572822,9111460148,ДшЫЙ7рйо,0,1,1';
my $regex = qr/(?:(?:.*?,){6})(?<email>.*?),(?:(?:.*?,){2})(?<phone>.*?),.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}