$re = '/(?:(?:.*?,){6})(?<email>.*?),(?:(?:.*?,){2})(?<phone>.*?),.*$/m';
$str = '55451,31.173.84.144,Ирина,10,100medspravok.com,,rinazhukova77@gmail.com,МСК,1481572814,9265837548,778899,1,0,1
55452,149.13.91.87,Антон,0,100medspravok.com,,adm.bitgram@gmail.com,МСК,1481572822,9111460148,ДшЫЙ7рйо,0,1,1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);