# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:.*?,){6})(?<email>.*?),(?:(?:.*?,){2})(?<phone>.*?),.*$"
test_str = ("55451,31.173.84.144,Ирина,10,100medspravok.com,,rinazhukova77@gmail.com,МСК,1481572814,9265837548,778899,1,0,1\n\n"
"55452,149.13.91.87,Антон,0,100medspravok.com,,adm.bitgram@gmail.com,МСК,1481572822,9111460148,ДшЫЙ7рйо,0,1,1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.