import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^arn:(?P<Partition>[^:\\n]*):(?P<Service>[^:\\n]*):(?P<Region>[^:\\n]*):(?P<AccountID>[^:\\n]*):(?P<Ignore>(?P<ResourceType>[^:\\/\\n]*)[:\\/])?(?P<Resource>.*)$";
final String string = "# ARN Format Templates\n"
+ "arn:partition:service:region:account-id:resource\n"
+ "arn:partition:service:region:account-id:resourcetype:resource\n"
+ "arn:partition:service:region:account-id:resourcetype/resource\n"
+ "# Amazon Simple Storage Service (S3)\n"
+ "arn:aws:s3:::my_corporate_bucket/Development/*\n";
final String subst = "Partition: \"\\1\"\\nService: \"\\2\"\\nRegion: \"\\3\"\\nAccountID: \"\\4\"\\nResourceType: \"\\6\"\\nResource: \"\\7\"\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}