$re = '/^arn:(?P<Partition>[^:\n]*):(?P<Service>[^:\n]*):(?P<Region>[^:\n]*):(?P<AccountID>[^:\n]*):(?P<Ignore>(?P<ResourceType>[^:\/\n]*)[:\/])?(?P<Resource>.*)$/m';
$str = '# ARN Format Templates
arn:partition:service:region:account-id:resource
arn:partition:service:region:account-id:resourcetype:resource
arn:partition:service:region:account-id:resourcetype/resource
# Amazon Simple Storage Service (S3)
arn:aws:s3:::my_corporate_bucket/Development/*
';
$subst = "Partition: \"\1\"\nService: \"\2\"\nRegion: \"\3\"\nAccountID: \"\4\"\nResourceType: \"\6\"\nResource: \"\7\"\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;