import re
regex = re.compile(r"^arn:(?P<Partition>[^:\n]*):(?P<Service>[^:\n]*):(?P<Region>[^:\n]*):(?P<AccountID>[^:\n]*):(?P<Ignore>(?P<ResourceType>[^:\/\n]*)[:\/])?(?P<Resource>.*)$", flags=re.MULTILINE)
test_str = ("# ARN Format Templates\n"
"arn:partition:service:region:account-id:resource\n"
"arn:partition:service:region:account-id:resourcetype:resource\n"
"arn:partition:service:region:account-id:resourcetype/resource\n"
"# Amazon Simple Storage Service (S3)\n"
"arn:aws:s3:::my_corporate_bucket/Development/*\n")
subst = "Partition: \"\\1\"\\nService: \"\\2\"\\nRegion: \"\\3\"\\nAccountID: \"\\4\"\\nResourceType: \"\\6\"\\nResource: \"\\7\"\\n"
result = regex.sub(subst, test_str)
if result:
print(result)