#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/[\S]+@[\S]+BOT"
Local $sString = "I have a regex to find something like /someChars1@someChars2BOT in java" & @CRLF & _
"" & @CRLF & _
"rules:" & @CRLF & _
"" & @CRLF & _
"1-the text has to start with / symbol" & @CRLF & _
"" & @CRLF & _
"2-someChars1 should contain at least 1 char or more (it could not be whiteSpace)" & @CRLF & _
"" & @CRLF & _
"3- someChars2 has to start with @ symbol and it could not be whitespace" & @CRLF & _
"" & @CRLF & _
"4- the text has to end with BOT word" & @CRLF & _
"" & @CRLF & _
"5- the text could not contain whitespace" & @CRLF & _
"" & @CRLF & _
"can someone help me? thank you in advance" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")