# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/[\S]+@[\S]+BOT"
test_str = ("I have a regex to find something like /someChars1@someChars2BOT in java\n\n"
"rules:\n\n"
"1-the text has to start with / symbol\n\n"
"2-someChars1 should contain at least 1 char or more (it could not be whiteSpace)\n\n"
"3- someChars2 has to start with @ symbol and it could not be whitespace\n\n"
"4- the text has to end with BOT word\n\n"
"5- the text could not contain whitespace\n\n"
"can someone help me? thank you in advance\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.