package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/[\S]+@[\S]+BOT`)
var str = `I have a regex to find something like /someChars1@someChars2BOT in java
rules:
1-the text has to start with / symbol
2-someChars1 should contain at least 1 char or more (it could not be whiteSpace)
3- someChars2 has to start with @ symbol and it could not be whitespace
4- the text has to end with BOT word
5- the text could not contain whitespace
can someone help me? thank you in advance
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}