use strict;
my $str = 'I have a regex to find something like /someChars1@someChars2BOT in java
rules:
1-the text has to start with / symbol
2-someChars1 should contain at least 1 char or more (it could not be whiteSpace)
3- someChars2 has to start with @ symbol and it could not be whitespace
4- the text has to end with BOT word
5- the text could not contain whitespace
can someone help me? thank you in advance
';
my $regex = qr/\/[\S]+@[\S]+BOT/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}