package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[a-z ,.'-]+$`)
var str = `John Doe
Martin Luther King, Jr.
Betty d'Angelo
Jonathon3
jane doe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}