// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^[a-z ,.'-]+$").unwrap();
let string = "John Doe
Martin Luther King, Jr.
Betty d'Angelo
Jonathon3
jane doe";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}