re = /^[a-z ,.'-]+$/im
str = 'John Doe
Martin Luther King, Jr.
Betty d\'Angelo
Jonathon3
jane doe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end