$re = '/^[a-z ,.\'-]+$/im';
$str = 'John Doe
Martin Luther King, Jr.
Betty d\'Angelo
Jonathon3
jane doe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);