#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)batiment restructur[eé]"
Local $sString = "plateaux entièrement rénovés XXXXXX immeuble de style industriel restructuré " & @CRLF & _
"" & @CRLF & _
"surface livrée rénovée et climatisée dans un magnifique immeuble haussmannien restructuré" & @CRLF & _
"" & @CRLF & _
"batiment restructuré XXXXXX plateau livré entièrement rénové et décloisonné " & @CRLF & _
"" & @CRLF & _
"parking exterieur restructuré XXXXX bureau rénové " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")