// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)batiment restructur[eé]").unwrap();
let string = "plateaux entièrement rénovés XXXXXX immeuble de style industriel restructuré
surface livrée rénovée et climatisée dans un magnifique immeuble haussmannien restructuré
batiment restructuré XXXXXX plateau livré entièrement rénové et décloisonné
parking exterieur restructuré XXXXX bureau rénové
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}