package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[.+:\/\/]?[^.]*\.?(?<name>[^.]+).+`)
var str = `https://www.google.com.ua/images/branding/product/ico/googleg_lodp.ico
https://www.google.com/images/branding/product/ico/googleg_lodp.ico
https://books.google.com.ua/images/branding/product/ico/googleg_lodp.ico
ftp://books.google.com.ua/images/branding/product/ico/googleg_lodp.ico
www.google.com.br
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}