import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[.+:\\/\\/]?[^.]*\\.?(?<name>[^.]+).+";
final String string = "https://www.google.com.ua/images/branding/product/ico/googleg_lodp.ico\n"
+ "https://www.google.com/images/branding/product/ico/googleg_lodp.ico\n"
+ "https://books.google.com.ua/images/branding/product/ico/googleg_lodp.ico\n"
+ "ftp://books.google.com.ua/images/branding/product/ico/googleg_lodp.ico\n"
+ "www.google.com.br\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}