re = /[.+:\/\/]?[^.]*\.?(?<name>[^.]+).+/
str = 'https://www.google.com.ua/images/branding/product/ico/googleg_lodp.ico
https://www.google.com/images/branding/product/ico/googleg_lodp.ico
https://books.google.com.ua/images/branding/product/ico/googleg_lodp.ico
ftp://books.google.com.ua/images/branding/product/ico/googleg_lodp.ico
www.google.com.br
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end