// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[.+:\/\/]?[^.]*\.?(?<name>[^.]+).+").unwrap();
let string = "https://www.google.com.ua/images/branding/product/ico/googleg_lodp.ico
https://www.google.com/images/branding/product/ico/googleg_lodp.ico
https://books.google.com.ua/images/branding/product/ico/googleg_lodp.ico
ftp://books.google.com.ua/images/branding/product/ico/googleg_lodp.ico
www.google.com.br
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}