using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(rpm)\s?\d+|\d+\s?(?1)";
string input = @"hotpoint nm11 823 wk eu n 1200 rpm 8 kg class a+++
hotpoint nm11 823 wk eu n rpm 1200 8 kg class a+++
hotpoint nm11 823 wk eu n rpm1200 8 kg class a+++";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}