$re = '/(rpm)\s?\d+|\d+\s?(?1)/';
$str = 'hotpoint nm11 823 wk eu n 1200 rpm 8 kg class a+++
hotpoint nm11 823 wk eu n rpm 1200 8 kg class a+++
hotpoint nm11 823 wk eu n rpm1200 8 kg class a+++';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);