re = /(rpm)\s?\d+|\d+\s?(?1)/
str = 'hotpoint nm11 823 wk eu n 1200 rpm 8 kg class a+++
hotpoint nm11 823 wk eu n rpm 1200 8 kg class a+++
hotpoint nm11 823 wk eu n rpm1200 8 kg class a+++'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end