#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z][0-9a-zA-Z_]+(\.{1})?[0-9a-zA-Z_]+(\.{1})?[0-9a-zA-Z_]+(\.{1})?[0-9a-zA-Z_]+\@[a-zA-Z_]+\.(com|[a-z]{3})(\.[a-z]{2})?"
Local $sString = "hgfsfkdasd.54mnfmbvm@ljk_shgfhjyjtjAgjyjh.sdm."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")