const regex = /^[a-zA-Z][0-9a-zA-Z_]+(\.{1})?[0-9a-zA-Z_]+(\.{1})?[0-9a-zA-Z_]+(\.{1})?[0-9a-zA-Z_]+\@[a-zA-Z_]+\.(com|[a-z]{3})(\.[a-z]{2})?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z][0-9a-zA-Z_]+(\\.{1})?[0-9a-zA-Z_]+(\\.{1})?[0-9a-zA-Z_]+(\\.{1})?[0-9a-zA-Z_]+\\@[a-zA-Z_]+\\.(com|[a-z]{3})(\\.[a-z]{2})?', 'gm')
const str = `hgfsfkdasd.54mnfmbvm@ljk_shgfhjyjtjAgjyjh.sdm.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}