import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z][0-9a-zA-Z_]+(\\.{1})?[0-9a-zA-Z_]+(\\.{1})?[0-9a-zA-Z_]+(\\.{1})?[0-9a-zA-Z_]+\\@[a-zA-Z_]+\\.(com|[a-z]{3})(\\.[a-z]{2})?";
final String string = "hgfsfkdasd.54mnfmbvm@ljk_shgfhjyjtjAgjyjh.sdm.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}