# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z][0-9a-zA-Z_]+(\.{1})?[0-9a-zA-Z_]+(\.{1})?[0-9a-zA-Z_]+(\.{1})?[0-9a-zA-Z_]+\@[a-zA-Z_]+\.(com|[a-z]{3})(\.[a-z]{2})?"
test_str = "hgfsfkdasd.54mnfmbvm@ljk_shgfhjyjtjAgjyjh.sdm."
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.