using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\""|')([^""|'|\s]|\\""*)*\..*(\""|')";
string input = @"""index.html"" // Correct
""/index."" // Correct
//Below Correct
<link rel=""icon"" type=""image/png"" href=""assets/icon/favicon.png"">
<link rel=""icon"" type=""image/png"" href='assets/icon/favicon.png"">
'/somedir/test.js' // Correct
<meta name=""viewport"" content=""viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no""> // Correct
Fails Below!!
<script type=""text/javascript"" src=""runtime.js""></script><script type=""text/javascript"" src=""polyfills.js""></script><script type=""text/javascript"" src=""styles.js""></script><script type=""text/javascript"" src=""cordova.js""></script><script type=""text/javascript"" src=""vendor.js""></script><script type=""text/javascript"" src=""main.js""></script></body>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}