const regex = /(\"|')([^"|'|\s]|\\"*)*\..*(\"|')/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\"|\')([^"|\'|\\s]|\\\\"*)*\\..*(\\"|\')', 'gm')
const str = `"index.html" // Correct
"/index." // Correct
//Below Correct
<link rel="icon" type="image/png" href="assets/icon/favicon.png">
<link rel="icon" type="image/png" href='assets/icon/favicon.png">
'/somedir/test.js' // Correct
<meta name="viewport" content="viewport-fit=cover, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no"> // Correct
Fails Below!!
<script type="text/javascript" src="runtime.js"></script><script type="text/javascript" src="polyfills.js"></script><script type="text/javascript" src="styles.js"></script><script type="text/javascript" src="cordova.js"></script><script type="text/javascript" src="vendor.js"></script><script type="text/javascript" src="main.js"></script></body>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}