using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*[1-9][0-9]*\s*(?=([., \t]))(?:\s*(?:\1|\r?\n)\s*[1-9][0-9]*)+\s*$";
string input = @"10 , 11 , 12 , 13 , 14 , 30
, 9 , 41 , 42 , 44 , 46 , 48
10 , 11 , 12 ,13 , 14 , 30";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}