import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*[1-9][0-9]*\\s*(?=([., \\t]))(?:\\s*(?:\\1|\\r?\\n)\\s*[1-9][0-9]*)+\\s*$";
final String string = "10 , 11 , 12 , 13 , 14 , 30\n"
+ " , 9 , 41 , 42 , 44 , 46 , 48\n"
+ "10 , 11 , 12 ,13 , 14 , 30";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}