$re = '/^\s*[1-9][0-9]*\s*(?=([., \t]))(?:\s*(?:\1|\r?\n)\s*[1-9][0-9]*)+\s*$/';
$str = '10 , 11 , 12 , 13 , 14 , 30
, 9 , 41 , 42 , 44 , 46 , 48
10 , 11 , 12 ,13 , 14 , 30';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);