import Foundation
let pattern = #"^\s*[1-9][0-9]*\s*(?=([., \t]))(?:\s*(?:\1|\r?\n)\s*[1-9][0-9]*)+\s*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
10 , 11 , 12 , 13 , 14 , 30
, 9 , 41 , 42 , 44 , 46 , 48
10 , 11 , 12 ,13 , 14 , 30
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}