#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:religion = (.*)|\d+(?:\.\d+){2} = {([^}]*)})"
Local $sString = "# 1 - Vestisland" & @CRLF & _
"" & @CRLF & _
"# County Title" & @CRLF & _
"title = c_vestisland" & @CRLF & _
"" & @CRLF & _
"# Settlements" & @CRLF & _
"max_settlements = 2" & @CRLF & _
"b_reykjavik = tribal" & @CRLF & _
"" & @CRLF & _
"#b_alftanes = city" & @CRLF & _
"#b_skalholt = temple" & @CRLF & _
"#b_pingvellir = castle" & @CRLF & _
"#b_kjalarnes = castle" & @CRLF & _
"#b_hvamm = castle" & @CRLF & _
"#b_hlidarendi = castle" & @CRLF & _
"#b_borg = castle" & @CRLF & _
"" & @CRLF & _
"# Misc" & @CRLF & _
"culture = norse" & @CRLF & _
"religion = zoroastrian" & @CRLF & _
"terrain = arctic" & @CRLF & _
"" & @CRLF & _
"# History" & @CRLF & _
"867.1.1 = {" & @CRLF & _
" b_reykjavik = tb_shipyard_1" & @CRLF & _
"}" & @CRLF & _
"900.1.1 = {" & @CRLF & _
" b_reykjavik = castle" & @CRLF & _
" b_reykjavik = ca_shipyard_1" & @CRLF & _
" b_alftanes = city" & @CRLF & _
"}" & @CRLF & _
"1000.1.1 = {" & @CRLF & _
" culture = norwegian" & @CRLF & _
" religion = zoroastrian = sunni = catholic" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")