using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:religion = (.*)|\d+(?:\.\d+){2} = {([^}]*)})";
string input = @"# 1 - Vestisland
# County Title
title = c_vestisland
# Settlements
max_settlements = 2
b_reykjavik = tribal
#b_alftanes = city
#b_skalholt = temple
#b_pingvellir = castle
#b_kjalarnes = castle
#b_hvamm = castle
#b_hlidarendi = castle
#b_borg = castle
# Misc
culture = norse
religion = zoroastrian
terrain = arctic
# History
867.1.1 = {
b_reykjavik = tb_shipyard_1
}
900.1.1 = {
b_reykjavik = castle
b_reykjavik = ca_shipyard_1
b_alftanes = city
}
1000.1.1 = {
culture = norwegian
religion = zoroastrian = sunni = catholic
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}