# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:religion = (.*)|\d+(?:\.\d+){2} = {([^}]*)})"
test_str = ("# 1 - Vestisland\n\n"
"# County Title\n"
"title = c_vestisland\n\n"
"# Settlements\n"
"max_settlements = 2\n"
"b_reykjavik = tribal\n\n"
"#b_alftanes = city\n"
"#b_skalholt = temple\n"
"#b_pingvellir = castle\n"
"#b_kjalarnes = castle\n"
"#b_hvamm = castle\n"
"#b_hlidarendi = castle\n"
"#b_borg = castle\n\n"
"# Misc\n"
"culture = norse\n"
"religion = zoroastrian\n"
"terrain = arctic\n\n"
"# History\n"
"867.1.1 = {\n"
" b_reykjavik = tb_shipyard_1\n"
"}\n"
"900.1.1 = {\n"
" b_reykjavik = castle\n"
" b_reykjavik = ca_shipyard_1\n"
" b_alftanes = city\n"
"}\n"
"1000.1.1 = {\n"
" culture = norwegian\n"
" religion = zoroastrian = sunni = catholic\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.