using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:UTF-8&q=+(.*)$|\?P=+(.*)$|\/search\/node\/+(.*)$)";
string input = @"/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=conserative+
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=congress+numbers
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=chemistry+degree
/search/?P=MBA 742
/search/node/adim account
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}