re = /(?:UTF-8&q=+(.*)$|\?P=+(.*)$|\/search\/node\/+(.*)$)/m
str = '/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=conserative+
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=congress+numbers
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=chemistry+degree
/search/?P=MBA 742
/search/node/adim account
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end