package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:UTF-8&q=+(.*)$|\?P=+(.*)$|\/search\/node\/+(.*)$)`)
var str = `/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=conserative+
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=congress+numbers
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=chemistry+degree
/search/?P=MBA 742
/search/node/adim account
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}