use strict;
my $str = '/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=conserative+
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=congress+numbers
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=chemistry+degree
/search/?P=MBA 742
/search/node/adim account
';
my $regex = qr/(?:UTF-8&q=+(.*)$|\?P=+(.*)$|\/search\/node\/+(.*)$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}