#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^,]*, ){7}'\K[^']+\.gov(?=')"
Local $sString = "(2843, '', 0, '', '', '', '', 'mail@yahoo.gr', '', '')," & @CRLF & _
"(2844, '', 0, '', '', '', '', 'mail1@washpost.com', '', '')," & @CRLF & _
"(2845, '', 0, '', '', '', '', 'someMail@gmail.com', '', '')," & @CRLF & _
"(2846, '', 0, '', '', '', '', 'else@gmail.gov', '', ''),"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")