$re = '/^(?:[^,]*, ){7}\'\K[^\']+\.gov(?=\')/m';
$str = '(2843, \'\', 0, \'\', \'\', \'\', \'\', \'mail@yahoo.gr\', \'\', \'\'),
(2844, \'\', 0, \'\', \'\', \'\', \'\', \'mail1@washpost.com\', \'\', \'\'),
(2845, \'\', 0, \'\', \'\', \'\', \'\', \'someMail@gmail.com\', \'\', \'\'),
(2846, \'\', 0, \'\', \'\', \'\', \'\', \'else@gmail.gov\', \'\', \'\'),';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);