use strict;
my $str = '(2843, \'\', 0, \'\', \'\', \'\', \'\', \'mail@yahoo.gr\', \'\', \'\'),
(2844, \'\', 0, \'\', \'\', \'\', \'\', \'mail1@washpost.com\', \'\', \'\'),
(2845, \'\', 0, \'\', \'\', \'\', \'\', \'someMail@gmail.com\', \'\', \'\'),
(2846, \'\', 0, \'\', \'\', \'\', \'\', \'else@gmail.gov\', \'\', \'\'),';
my $regex = qr/^(?:[^,]*, ){7}'\K[^']+\.gov(?=')/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}