# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[^,]*, ){7}'\K[^']+\.gov(?=')"
test_str = ("(2843, '', 0, '', '', '', '', 'mail@yahoo.gr', '', ''),\n"
"(2844, '', 0, '', '', '', '', 'mail1@washpost.com', '', ''),\n"
"(2845, '', 0, '', '', '', '', 'someMail@gmail.com', '', ''),\n"
"(2846, '', 0, '', '', '', '', 'else@gmail.gov', '', ''),")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.