# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:((?<=\[)(.*?)(?=\])))+//g;t' <<< "[MercadosArmados.GpoMerc-CTN3].[Mercado Marketing SNC].[Mk Alprazolam], [MercadosArmados.GpoMerc-CTN3].[Mercado Marketing SNC].[Mk Amantadina]"