const regex = /(?:((?<=\[)(.*?)(?=\])))+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:((?<=\\[)(.*?)(?=\\])))+', 'g')
const str = `[MercadosArmados.GpoMerc-CTN3].[Mercado Marketing SNC].[Mk Alprazolam], [MercadosArmados.GpoMerc-CTN3].[Mercado Marketing SNC].[Mk Amantadina]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);