import re
regex = re.compile(r"(?:((?<=\[)(.*?)(?=\])))+")
test_str = "[MercadosArmados.GpoMerc-CTN3].[Mercado Marketing SNC].[Mk Alprazolam], [MercadosArmados.GpoMerc-CTN3].[Mercado Marketing SNC].[Mk Amantadina]"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)